3 Replies Latest reply on Aug 1, 2017 2:26 AM by user14047

    Issues with theme icons

    darrenadams

      Hello,

       

      I've recently switched our organisation from FileMaker 13 to FileMaker 15. There were a number of reasons for this, but one of those reasons was that it would give me the opportunity use some of the new interface features, such as icons in buttons and button bars.

       

      However, I seem to have run into an issue that I don't know how to get around. I've attached a screen shot that demonstrates this. In the screenshot, I have created a layout that includes a button bar with a single button. When I try to add an icon to it (this is one of the stock icons, but it happens with any type of SVG icon I use), the button bar seems to render it correctly with transparency. But when I try to do add an SVG image to a regular button, the SVG has a which background behind it.

       

      I imagine that I could go down the route of re-creating my theme and basing it on one of the more modern themes, but I've put a lot of work into the theme and would rather not do that. Does anybody know what might be causing that background to appear on a themed button in this way? And if so, what can be done to rectify it?

       

      To summarise

       

      • I'm migrating a solution from FileMaker Pro 13 to FileMaker Pro 15
      • SVG images render correctly on button bar object
      • SVG images do not render properly on button objects. The buttons were themed in FileMaker Pro 13

       

      I've also attached a sample fmp12 file that demonstrates this issue, should anybody want to see for themselves