6 Replies Latest reply on Aug 4, 2017 11:23 AM by sai

    Can't connect FMGO to FM Pro Advanced

    sai

      I believe I have tried everything to connect to my FM App on my MacBook Pro from my iPhone, but so far no luck.

      Bot the Mac and the iPad are running FM 16.

       

      Here's what I've done:

      1) start the app on the Mac

      2) I set up "Share with FM Clients". Network Sharing ON, TCP/IP Address correct for my WiFi network, set the Network Access to "ALL USERS" in the open file.

      3) Set up sharing on my Mac to allow File Sharing with the folder containing the App File.

      4) On FMGO I go into Hosts.  It says "Waiting for Response", then "No Files Available"

      5) I then clicked on "Hosts" in the upper left corner of the FMGO Screen.  I see my Host and select it.

      6) I then get "Waiting for Response", then "No Files Available" again

       

      Can anybody tell what I am doing wrong?

        • 1. Re: Can't connect FMGO to FM Pro Advanced
          TSPigeon

          sai:

           

          Thank you for your post!

           

          -Verify the File is open in FileMaker Pro for it to actively host it.

          -You can use File > Open Remote with Pro to see itself as a host and see if the files display.

          -In File > Sharing > Share with FileMaker Clients... verify the "Don't display in Launch Center" is unchecked.

          -FileMaker Go is more sensitive with File Names, so verify there are only alphanumeric characters and underscores "_".

          -It may also be a firewall configuration preventing communication on 5003.

           

          Your results for the troubleshooting above might help us come up with further steps to take.

           

          I'm also going to move this thread from the FileMaker Community Feedback Space (which is specifically for input on the Community itself) to the Discussions Space where you should receive more views and potentially more feedback on this topic!

           

          TSPigeon

          FileMaker, Inc.

          • 2. Re: Can't connect FMGO to FM Pro Advanced
            sai

            I opened the file, then I used open remote and I did see the file and it opened with a red lock icon (displayed as an open lock which I think means the connection is not encrypted).  I checked the firewall and turned if off and it displayed the file and I was able to connect. 

             

            Thanks so much for your help!

             

            One more question, how can I configure the mac to allow connection on port 5003?

            • 3. Re: Can't connect FMGO to FM Pro Advanced
              TSPigeon

              I'm glad we could find the cause!

              You might find this article useful to configure: OS X: About the application firewall - Apple Support

               

              TSPigeon

              FileMaker, Inc.

              • 4. Re: Can't connect FMGO to FM Pro Advanced
                sai

                I'm still a little confused about the fact I can't connect without turning off the firewall.  I configured the Mac to allow connections to FM16 but it still didn't work unless I turn off the firewall.  I then Port forwarded port 5003 in my router and still no luck.  This is a local wifi network so port forwarding should work unless the port is not 5003.  Is that possible?  Could FMGO try to connect on a different port and then switch to 5003?  If so I would have to port forward two ports.  Please let me know your thoughts.

                • 5. Re: Can't connect FMGO to FM Pro Advanced
                  TSPigeon

                  sai:

                   

                  FileMaker Go does use just port 5003 to connect to the hosted database. It doesn't sound like just adding FileMaker Pro to the Firewall opened port 5003. Have you rebooted the machine and tried hosting and connecting again?

                   

                  TSPigeon

                  FileMaker, Inc.

                  • 6. Re: Can't connect FMGO to FM Pro Advanced
                    sai

                    That did it!!

                     

                    Thanks.