AnsweredAssumed Answered

FM Server 16 - Windows Server 16 Install - Error - The following ports are in use: 80

Question asked by kavery on Aug 4, 2017
Latest reply on Nov 4, 2017 by aknudsen

I am currently trying to reinstall FMServer 16 on a virtual machine running Windows Server 16 and I'm getting the following error:

 

The following ports are in use: 80.

Port80inuse.jpg

 

I was able to install it initially a month or so ago, and it had full functionality. In the meantime, I installed Windows updates, and was waiting on my organization to request our SSL certificate. I installed the SSL certificate successfully, then restarted, and shut down my connection for the evening. When I came in the next day I could no longer log into the FM Server. So I uninstalled it and everything else that FM Server requires. I then spent over 2 hours on the phone with FileMaker support trying to reinstall to no avail.

 

As previously stated, I did install it initially with full functionality. However, I had to disable certain things, and stop things from the command prompt, and didn't write down the install process and I can't remember or get FM Server to install using ports 80 and 443 at all. It will error out once I get to the Deployment Assistant, 3. Technologies screen when selecting yes to any of the Web Publishing options. If I select different ports during install (EX: 8080 and 4443) then try to edit deployment later, web publishing doesn't work and I get the following errors during testing:

 

Test web server (http://...8080/fmi-test/text.xml): Connection refused: connect

 

OR sometimes:

 

503: Value in field is not within the range specified in validation entry options.

 

This is all despite the fact that I have the rule set up in the Windows Firewall to allow the TCP ports (including the testing 8080, and 4443 ports as well) to be allowed and enabled for FMserver.exe per the instructions from the link below:

http://help.filemaker.com/app/answers/detail/a_id/15997/~/configuring-windows-and-os-x-firewalls-for-filemaker-server

 

I'm back at square one now. Things to note are as follows:

 

1. The only programs installed on the VM are:

- Active Directory (Used by myself and other members logging directly into the VM)

- Duo Authentication (2fa)

- MS Office Pro Plus 2013 (This VM is also used for data backup)

- VMware Tools (If not installed, I have no control over a mouse or keyboard, etc.)

 

2. FileMaker Support suggested stopping the following services if I have them (and this didn't help):

- Microsoft SQL Reporting Service

- Microsoft Web Platform Installer

- Microsoft Web Deployment Agent Service

- Microsoft Windows Media Services

- World Wide Web Publishing Service

- Various security software (firewall, anti-virus, etc.)

- Apache installations

 

3. IIS is now using ports other than 80 and 443.

 

4. From the Command Prompt, if I run netstat -nab, I get the following listed in active connections for port 80:

 

     Can not obtain ownership information

 

However, when I run netstat -ao, I can see that PID 4 is listening to port 80. On my machine, PID 4 is NT Kernel & System, which obviously can't be disabled.

 

At this point, I don't know what else to do and we need to get FMServer 16 up and running. If anyone has any advice or has encountered this issue, what have you done to rectify it permanently?

 

Thanks!

Outcomes