10 Replies Latest reply on Aug 5, 2017 6:07 AM by beverly

    Text alignment leaves too much space between fields

    user28268

      I'm creating a form that uses "first name" and "last name" fields side by side. I have "first name" right aligned and "last name" left aligned, but there is too much space between the names when the fields are placed next to each other. I've been able to reduce the space by overlapping the fields slightly (too much overlap and the text in one field gets covered up). This form is a "certificate of completion" so I want it to be attractive.

       

      How can I shrink this space?

        • 1. Re: Text alignment leaves too much space between fields
          beverly

          Merge fields on layout (left align). Add tab character between the two fields. Set a final tab stop that can be Right Aligned with a space for the fill character.

           

          Beverly

          • 2. Re: Text alignment leaves too much space between fields
            user28268

            Beverly,

            Thank you for replying so quickly. Unfortunately my FM skills aren't good enough to understand your instructions. I'm kind of an experienced beginner depending on the task.

             

            I found "Merge Field" in the Insert menu and after that, I'm lost. I already have my 2 fields in place. Do I delete them and start fresh with Merge? It seems to insert the field selected. Which field do I select from the Merge command? Is the tab inserted with the tab key on my keyboard or from the Tab Control Menu? I obviously need more background and step-by-step instructions.

            • 3. Re: Text alignment leaves too much space between fields
              beverly

              Insert on field, add a tab character (keyboard), then insert the second field.

              Resize the width of your "block of text" to the desired size.

              With the text already selected, open Inspector and navigate to Appearance and scroll to the bottom "Tabs".

              Create/set a tab stop at the width of the block (or near the last character).

              Make sure it is "Alignment Right" and the Leader is one space character.

               

              Beverly

              • 4. Re: Text alignment leaves too much space between fields
                user28268

                Beverly,

                I feel really stupid here. I'm in Layout Mode. I have "first name" field inserted. I hit the "Tab" key on my keyboard and all it does it totally screw up my layout "This operation will cause objects to extend off the layout. Do you wish to increase the size of the layout to accommodate the objects?" No tab gets inserted into my layout. When I go to the Inspector, I press + to add a tab stop, and I can put in the number, but it doesn't allow me to put in the "alignment" until after I've save the stop position, then go back and click on it. It doesn't seem to save the "Leader" amount since it won't let me put in a number until after I've "saved" the stop position, then it doesn't show up afterward when I go back to look.

                 

                In addition, I'm not clear on how this tab is going to reduce the space between the text in my fields when they're already right and left aligned. It seems like this will add more space or do nothing at all. I'd send a picture if I could.

                 

                The rest of my form is all text boxes, though I will eventually add a date field when I get this other problem figured out.

                 

                Perhaps I'm supposed to set up my database so that "first name" and "last name" get combined into a third "full name" field so there is no gap between the names???

                 

                Sorry I'm not getting it. I'm not usually this dim. Thanks for your patience.

                • 5. Re: Text alignment leaves too much space between fields
                  philmodjunk

                  Did you check the padding on these fields? Seems like you might have more padding than you want.

                  • 6. Re: Text alignment leaves too much space between fields
                    user28268

                    That sounds promising! Where do I find that? I didn't see it in the menu anywhere.

                    • 7. Re: Text alignment leaves too much space between fields
                      user28268

                      Okay, here's something weird. I changed themes because I realized that my background color was not white like I wanted. When I did, the spacing between the text in the fields disappeared completely. Now the names have no space in between! Sheesh! Padding is probably the answer.

                      • 8. Re: Text alignment leaves too much space between fields
                        philmodjunk

                        It's a setting on the appearance tab, but like Beverly, I might set up merge field text but just choose center alignment  for the block of merge text to make this work myself.

                         

                        To do that:

                         

                        1. Delete your current two fields.
                        2. Click the text tool and then click your layout to start a bit of Layout text. Don't worry about where, you'll drag it into position later.)
                        3. Now use the insert menu to select the merge field option and add the first field. Press the space bar to add a space or enter whatever text you want between the fields.
                        4. Use insert menu again to add the second field.
                        5. Click the arrow in the tool bar to stop editing text.
                        6. Drag the text to where you want it and use either the text formatting toolbar or the inspector to specify center alighment.
                        • 9. Re: Text alignment leaves too much space between fields
                          user28268

                          Thanks! I'll try it out next time I have a chance to work on this project.

                           

                          Peggy

                          • 10. Re: Text alignment leaves too much space between fields
                            beverly

                            Keyboard insert tab character depends on OS.

                            MacOS: option & tab

                            Win: cntrl & tab

                             

                            I'm sorry this was not the answer you seek.

                            Beverly