0 Replies Latest reply on Aug 9, 2017 11:39 AM by BillisSaved

    Buttons in portals responding slowly.

    BillisSaved

      Good afternoon everyone,

       

      I hope your day is going well. Thanks in advance for any assistance and/or advice you are willing to provide! I've run into what seems to be a performance issue, but I have been unable to determine the cause. I've implemented the Selector/Connector architecture into my solution, and I'm using a multi-key value in one of the fields in the SELECTOR table occurrence to define the relationship to the child table occurrence ( Selected_Documents ). I've configured a portal to point to the child table occurrence ( Selected_Documents ) and inserted a field which displays the name of the appropriate documents. The intended function of this part of my solution is working as expected in all respects except performance.

       

      I've configured the document name field as a button, which will open the document in it's native application when clicked. The performance problem is a  2 - 3 second delay between the time the button is clicked and the perform script action associated with it activates. If I copy the field and move it outside of the portal, the perform script action appears in the script debugger immediately.

       

      I've tried everything I can think of to find the root cause of this delay and have had no success. Thanks so much for taking the time to consider this issue. Have a great day!

       

      God bless,

       

       

      Bill