AnsweredAssumed Answered

FM Server problem exporting field to Temp

Question asked by justinc on Aug 16, 2017
Latest reply on Aug 17, 2017 by Vincent_L

I'm having an issue attempting to export a container field to the Temporary directory on a file hosted on FMS 15.03.

 

This script works fine when I run it locally on OSX.

 

The script imports an image file from a URL.  The file is named in a jumbled manner and I want to rename it to something more human readable.  So I'm trying to export the image from the container into the Temp directory, using a new filename, and then reimport that back into the container.  I'd like to have this process run as part of a PSOS call ultimately - hence running it on the server.

 

The container is a global container; the field IS on the layout in question.  The import process from the URL works fine.  When it hits the 'export field contents' step, though, I get this error:

3     Command is unavailable (for example, wrong operating system or mode)

 

I build the filename from other data in the system, collect the TempDir path into a variable, then build the full path (path+filename) into another variable, before calling the

Here is an example of the path that it's using to export to (I have tried both of these forms):

filewin:/C:/Windows/Temp/S687/An.jpg

/C:/Windows/Temp/s697/An.jpg

 

Here's the sequence of script steps - insert from URL is at the top, then at line 74 is where the error happens:

 

Screen Shot 2017-08-16 at 17.56.29 .png

 

What am I missing here?

 

Thanks

Justin

Outcomes