JeffHenry

FMS 16 Thawte SSL - Unable to import with Intermediate certificate

Discussion created by JeffHenry on Aug 30, 2017
Latest reply on Aug 31, 2017 by JeffHenry

Hi Community,

 

We are attempting to install a Thawte SSL with an intermediate certificate. We are able to successfully install the Thwate SSL without the intermediate SSL, but this doesn't quite resolve to an encrypted connection with FMP, so we know we need the intermediate as well.

 

Here is the error we receive when attempting to import the intermediate SSL:

 

Screen Shot 2017-08-30 at 8.58.37 AM.png

 

We have tried a few different variations of getting the intermediate installed.

1. We include it in the Admin Console Import dialog.

2. We concatenated the root certificate with the intermediate certificate, as specified in the FileMaker documentation.

3. We included a intermediate bundle provided by Thawte in the Admin Console Import dialog.

 

All three of these attempts results in the same error.

 

I've double checked the .pem files to make sure there are no extra carriage returns or bad data. The intermediate certificates are taken from a webpage on Thawte, so I was required to copy/paste and save using a text editor. WordPad was used, but still saved with a valid .pem extension.

 

Has anyone else experienced this error and know how to resolve?

 

Thanks!

 

- Jeff

Outcomes