AnsweredAssumed Answered

Many to Many Relationship Portal Records Don't Display

Question asked by KathrynMalley on Aug 30, 2017
Latest reply on Sep 1, 2017 by BruceRobertson

The database is for registering riders into a horse show that is held annually.  Vaccination records have to be obtained for the horses to satisfy requirements of the state veterinarian.  One horse can have more than one rider (different age divisions or classes), and vice versa, some people bring more than one horse to ride. 

 

One aspect of "registration" is to register people into the "year."  There is a bridge table "Registrations" to link "People" and "Years."  On the "People" layout, the portal to select "Year" is working, AND displays all the years ever selected.

 

A similar functionality is needed either from the "People" point of view, or the "Horse" point of view to assign the horse to the people, and vice versa.  The bridge table is HorsesRiders.  A portal on the "People" layout is working to assign a horse to a rider, AND a portal on the "Horses" layout is working to assign a rider to a horse, BUT once I have navigated out of the box to make a selection, the data no longer appears.  i.e., if on the "People" layout, the box for horses appears blank.  I can see that the HorsesRiders record exists, i.e, that the horse and rider are paired, but the portal box appears empty on the People Layout as well as the Horses Layout.  In fact, I assigned myself to my horse successfully twenty times. 

 

Whereas it's working on the "Registration" functionality to register for a year, it is not for the horse and rider functionality.  Here are the screen shots.  Any help would be much-appreciated, thank you!

 

Screen Shot 2017-08-30 at 4.54.54 PM.png

 

Screen Shot 2017-08-30 at 5.15.19 PM.png

 

Screen Shot 2017-08-30 at 5.16.25 PM.png

Outcomes