AnsweredAssumed Answered

Multipart/Mixed HTTP request not working using filemaker 16 cURL

Question asked by riadh2002 on Sep 23, 2017
Latest reply on Sep 24, 2017 by riadh2002

According to google calendar API a batch request is of the form:

 

POST /batch
Host: www.googleapis.com
Authorization: *accesstoken*
Content-Type: multipart/mixed; boundary=batch_foobarbaz
--batch_foobarbaz
Content-Type: application/http
Content-ID: <item1:x@barnyard.example.com>
GET /calendar/v3/calendars/calendarId/events/eventId
--batch_foobarbaz--

 

When I try to use Filemaker 16 insert from URL I set the following parameters

 

URL Parameter is set to :

"https://www.googleapis.com/batch"

While cURL options are set to:

 "-X POST -H \"Content-Type: multipart/mixed; boundary=batch_foobarbaz\"
-H \"Authorization: *accesstoken*\"
-H \"Content-Length: *length*\"
--data \"--batch_foobarbaz
Content-Type: application/http
Content-ID: <item1:x@barnyard.example.com> 
GET https://www.googleapis.com/calendar/v3/calendars/*CalendarId*/events/*EventId* 
--batch_foobarbaz--\""

  

I always get a response BAD REQUEST response

 

what am I doing wrong?

Outcomes