AnsweredAssumed Answered

Odd behavior with FMP Adv. 16 & other Apps.

Question asked by SteveMartino on Sep 30, 2017
Latest reply on Oct 3, 2017 by SteveMartino

I came across an odd problem, and was wondering if anyone else had the same problem.

When I open my FM DB, and run this script it works fine.  If I then open up any other application-QuickBooks, Excel, Word, etc., it fails to work properly.  The only way it works properly is if I close the DB, and re-open.

Consequently, if I have open any other app, or multiple apps, then open FM, it works fine.

I tried this on other FM databases I created, and even took a starter solution, added the script and some records, with the same results.

Attached is the file.

To replicate this behavior do the following:

1.  Start on 'Dashboard' layout.

2.  Click the 'Print' Button'.  You may have to change to one of your printers (not sure).  When the Print dialog opens, where you can select how many copies, etc., just hit cancel.  Then you will go to the next record, and so on.

What should happen:

As you hit cancel, the screen will move to the next record (for printing).

What actually happens:

The print dialog continues to pop up and either one of two things will occur:

a) You don't visually see the layout moving to the next record.

b)  You don't even see it switch from the 'Dashboard' layout to the 'Print' layout.

 

I even tried re-installing FM-no luck.

I also tried switching it from a card layout to document, dialog & floating-no luck.

I"ll try tomorrow putting this on my Windows 8 laptop to see if I get the same results.

 

If anyone has any ideas, I would greatly appreciate it. 

Thanks

Steve

FMP Adv 16

Win Prof 7

Attachments

Outcomes