AnsweredAssumed Answered

Performing a find in related SQL field returns no results

Question asked by johnm on Oct 2, 2017
Latest reply on Oct 2, 2017 by johnm

Hello,

I have two slaves (dev and live) that export filmmaker data to mySQL and the Filemaker database also connects to an SQL database for data from another system. In the dev system, I'm trying to perform a find using one of the SQL fields through a relationship and it's returning zero records, even though I can see the value I'm looking for in the table view. I can also find the value when looking at the SQL table directly. The strange part is there is no issue on the live system. Related finds are working correctly.

I've rebuilt the ODBC connection as well as the TO's. Tried versions 14, 15 and 16 of fmpa and get the same result. Running on Windows 10 with the latest patches. Also pulled a backup file and did a recovery which showed one error related to the theme.

I've also pointed the slave at the same FM database that the live system is using and still get no results returned.

Any suggestions would be appreciated.

Thanks,

John

Outcomes