AnsweredAssumed Answered

FileMaker backup failed due to lock conflicts with users which crashes db, and FMS needs a restart.

Question asked by User26920 on Oct 26, 2017
Latest reply on Oct 26, 2017 by imarc

Hello There

 

We're getting a bizzarre situation where something to do with users staying connected to a database overnight; while backup schedule tried to run and potentially a record lock conflict between users seems to be preventing FMS from backing a file up.  On top of that after these 3 consecutive FMS errors within a minute the file is unusable and FMS needs to be restarted in order for it to go back to normal.  I tried a file recovery and FMP said that it was not damaged.  Since that file recovery and initial restart we've had this same error since the first occurrence around 4 -6 weeks ago, we've had it about 4 more times.  I screenshot here (also attached so that you can see all the text) the 3 consecutive Server error emails all in the same minute with timestamps.

 

 

I would like to ask if anybody has experienced the same problem with 14.0.4 or any version of FileMaker Server or can provide any further insight on what we can do next to try to prevent this from happening.  You can ask any further questions if you need to, to help troubleshoot maybe.  Many Thanks.

 

Thank you

User26920

Attachments

Outcomes