AnsweredAssumed Answered

unknown error -1743 when running AppleScript from FMP script

Question asked by mw_1 on Nov 2, 2017

I'm using FileMaker Pro 15 Advanced on my iMac running 10.13.1. When I close my FMP DB it triggers a script (Perform AppleScript) that updates my Calendar. This has been working for many years but yesterday I started getting unknown error -1743

 

The script looks like this:

 

tell application "Calendar"
  activate
  set theCalendar to "iFMP"

  if calendar theCalendar exists then
       tell calendar theCalendar
            delete every event
       end tell
  else
       tell me to beep 5
       make new calendar with properties {name:theCalendar, color:{64507, 41891, 1542}}
  end if
  reload calendars
end tell


-- execution of AppleScripts called from FMP is asynchronous; therefore, I'm adding this semphor to sync the execution
tell application "FileMaker Pro Advanced"
  tell table "t.Global"
       set data of cell "g.Semaphor" to "go"
       beep
  end tell
end tell

 

As soon as the script tried to manipulate the Calendar (line 7) it triggered this -1743 error.

 

However, using the same AppleScript run from Script Editor worked without errors.

 

Strange thing now is that today all is working again.

 

Yesterday, I had tried to update the Privacy settings for the Calendar app as there were no apps defined that were allowed access to Calendar. But there was no option to manually add an app to allow it to access the calendar.

Checking the Privacy setting today, I noticed that Calendar is now allowing access for FMP and CoreServicesAgent.

Outcomes