AnsweredAssumed Answered

FileMaker Pro Advanced on a Windows Server

Question asked by lylacinc on Nov 3, 2017
Latest reply on Nov 3, 2017 by lylacinc

I have a client that is a government agency.  They have been using an application I developed for them for 6 years.   They ended up purchasing a program to be used in all of the facilities across the nation.    So therefore my application is being phased out.   The supervisor that I developed the system for fought to get another year (or so) use out of the FileMaker application but it was contingent upon me redeveloping it using webdirect, because her users can no longer have FileMaker installed on their desktops.

 

My only access in to do support (they are in another state) over the past 6 years was to log in through their Citrix server.  I did all support and development at night while the users were off the system, by using logging into their server (Citrix to Remote Desktop), shutting down FileMaker Pro Server (14); starting up FileMaker Pro Advanced (14).   That is how I worked until September of last year.   It has taken over a year to get a new contract,  and in the meantime the application has been updated to run fully in webdirect.   Over the past year,  since my contract had expired, I have not logged in to do any support on the system.

 

Fast forward to today:


Their IT had to install FileMaker Pro Server 16 and FileMaker Pro Advanced 16 on the server for me as I do not have administrative rights on the server.  That was completed.  Their server is a Windows Server 2012 R2 Standard Edition with Update.  We tested webdirect and the users are able to access the files.  So today today I needed to import the data from the old set of files to the new set.      I started up FileMaker Pro Advanced 16 on the server, and to my dismay, some of the features are grayed out.  I have full access privileges in the files.  But I cannot Import and I cannot access scripts.  There were other functions grayed out but those are the 2 that are important to me right now.

 

Does FileMaker Pro Advanced no longer fully function on a windows server? 

 

When I ran into this issue, I worked with someone in IT who logged into the old server (which had already been shut off because we were doing the transfer) only to find that FileMaker Pro Advanced (14) on the old server also had functions grayed out.   I know those fuctions worked in the past.

 

If they no longer work, I need to find some kind of work around.  I'm pretty sure they will not give me VPN access.  Having them send me the current set of files is quick and then I could do the import here.   However, sending files back to the facility means me creating a DVD, that DVD has to be scanned and approved, which could take a week, and they can't afford a week of downtime.   But that doesn't address the ability for me to access scripts, which would be necessary to continue to do support. 

 

Any advice is appreciated!
Lynda

Outcomes