AnsweredAssumed Answered

"Go to Field" or "Go to Object" does not work above FM GO 13

Question asked by tackermax on Nov 6, 2017
Latest reply on Nov 7, 2017 by tackermax


Our script that uses "Go to Field" allowed us to open a Filemaker GO layout and start with the cursor in an item number field so that a barcode scanner can instantly access a record.

Once we updated FM GO to 15 or 16, that step is now broken, and our users have to tap the field prior to barcode scanning. This is the beginning steps that used to work. It's a script trigger on layout open for GO ipad.

 

 

I have tried the following script steps in many variances, not necessarily in this order, without any success:

 

"Go to Object" (naming the field)

Refresh Window

Commit Records

Go to Layout then go to field.

Select Window

 

I've tried putting in duplicate steps before and after the find. Zero luck getting the cursor to start in that field.

It used to work with just "Go to Field". I've seen this question/problem in a lot of posts, but none of the resolutions seem to fix my problem specifically.

 

Workaround: found another iPad that still had iOS 10, which allows 32-bit apps. FM GO 13 works fine with this step. Going forward, this is going to need fixing. We are running FM Server 15 on Windows 2012 R2.

 

Outcomes