AnsweredAssumed Answered

ODBC Data Source Missing

Question asked by slaman on Nov 15, 2017

I am trying to import data via an ODBC connection to an external MySQL database into FileMaker.  I can set up an External Data Connection fine in FileMaker Pro, and I can see the System DNS fine.  However, I get a "Data Source Missing" message when I visualize relationships.


I am able to set up the System DNS correctly.  When I test the connection using ODBC Administrator, it says that it works successfully.


System specs:

  • FileMaker Pro for Mac OS: v13.0.9 & v14.0.6 (I've tried both)
  • ODBC Driver for Mac OS: Actual Technologies, OpenLink v6.x, and OpenLink v7.x (I've tried all three)
  • MySQL for Windows: v5.6.21


I'm at a loss as to what to do next.  The weird part is that it worked a couple of months ago when I first tried (I believe we were using the OpenLink v6.x ODBC driver), but then didn't work after I retried recently.  Nothing has changed from the FileMaker Pro side of things.  I have tried to uninstall and reinstall the ODBC drivers.  I have tried to delete and re-add the System DNS connections in ODBC Connections.


Please help!