AnsweredAssumed Answered

FM Go not displaying field data in Web Viewer on new Layout

Question asked by yancmo on Nov 28, 2017
Latest reply on Nov 29, 2017 by yancmo

Hello all!

 

I'm working on a "Flash Card" app. (I'm sure there is some out there I could use but I thought this would be the best way for me to learn. Create my own.)

 

So far I have ended up using a Webviewer to display my questions on layout 1 so that I can scroll and not edit. Then clicking the question will either

1. Pop up a "card" with a WV to display the answer or

2. Take me to a 2nd layout with a WV. Some of my questions will contain inline graphics too so I prefer the new layout. (I'm sure I'll be asking about that later).

 

Both options seem to work fine on the PC but not FM Go.

 

When I click my Question as a button and am taken to the new layout the WV is blank. If I leave the WV on the same layout it displays fine in IOS. The issues seems to be with going to the new layout on FM Go.

 

My current script is

 

Go to Layout [ “iOS Answers Pop up Card” (Questions) ]

Go to Object [ Object Name: "AnswersWebViewer" ]

Set Web Viewer [ Object Name: "AnswersWebViewer"; URL: "data:text/html," &

"<html><head><meta name='viewport' content='initial-scale=1.0' />

<style>

*{font-size:20px;-webkit-text-size-adjust:100%;font:arial;}

</style></head>" &

GetAsCSS ( Answers::Answer_01 ) &

"</html>" ]

 

I'm using FMPro 16 Advanced Windows 10

FM Go 16 on ios.

 

Thank you for your time!

Yancy

Outcomes