user10625

Odd Debugger Slowness

Discussion created by user10625 on Nov 29, 2017
Latest reply on Dec 11, 2017 by TSGal

FMPA  16.0.3,  also saw it in FMP 15.0.4

MAC osx 10.12.6   (I think I have also seen it on windows).

Talking to FMS 16 ... on Windows Server 2008 R2

 

I have a script.  The script does a whole bunch of things.    At one point, it goes to a layout on a table, writes to a field, and then goes to the next record, and exits after last.  Just your typical loop.  I noticed that with the debugger on, FMP will give me the circlely waiting rainbow for sometimes up to a minute.  Just to set 1 field in 1 record.

 

OK, so I tried removing all fields from the layout.    Same issue.

 

When I am not in the debugger, everything is fast . . no problems.

 

I checked and the field that is being set is not referenced by any other fields, so there's no weird auto-enter being triggered or anything like that as far as I can tell.  (And again, it's not an issue when the debugger is off.)

 

It only seems to happen on this particular table, when in the debugger.

 

Also, I tried isolating just those script steps, and making a test script from them.  When I run this script, both in the debugger, and outside of the debugger, it runs fast and speedy.

 

Also...note that the Data Viewer is OFF/Closed in all cases.

 

So this suggest that either:  I am missing something obvious (but I think I've covered all of the bases), or.  . .

the debugger references something, maybe a calculation somewhere, in the rest of that script, and is trying to resolve that thing,  although there is no real reason to do so.   It's like the Data Viewer is  ON, and there is some weird ExecuteSQL calc that's in there firing off and taking forever.  Except that the Data Viewer is not on. 

 

 

 

Workaround (if any):   don't set the field, and/or don't run the debugger.

Outcomes