AnsweredAssumed Answered

Connect to PostgreSQL

Question asked by rigidrider on Dec 11, 2017
Latest reply on Dec 12, 2017 by rigidrider

Unable to connect to PostgreSQL with FM 16 ESS using Actual Driver 4.1.1.

 

I receive the below error message when attempting to connect (when authentication dialog box appears within FM relationship graph when adding an external table).

 

Error: The ODBC data source you have selected is not supported”


RUNNING

- Actual ODBC Driver for Open Source Databases ver 4.1.1

- Filemaker (“FM”) 16 Adv (local)

- Postgres 9.5.1 (localhost)

- Mac OS 10.13.1

 

I have also tried different vers of Postgres (9.3, 9.4, 10) and now have tried with 9.5, all without FM connection success.

 

* The Actual driver tests connection “successfully” when configuring the system DSN to PostgreSQL.

* The same Actual Driver works successfully connecting to a MySQL instance on same mac.

* PostgreSQL GUI interfaces (PGAdmin III and Postico) successfully connect to the PostgreSQL.

 

Any suggestions would be greatly appreciated. Thank you!

 

- Jim

 

 

 

 

Outcomes