AnsweredAssumed Answered

Send Mail via SMTP error 1506 - Gmail

Question asked by liveoaksf on Dec 14, 2017
Latest reply on Dec 14, 2017 by liveoaksf

Filemaker (v15) Send Mail script step works fine when I specify my own ISP's mail server. But using our business's Gmail server, it fails with unhelpful error 1506: "Email(s) could not be sent successfully."

 

I've tried all valid combinations of ports, protocols, and auth methods, although from our desktop email clients—Outlook and OS X Mail—we always just use standard TLS settings:

 

server: smtp.gmail.com

port: 587

protocol: TLS

auth: plain password

 

...and that always works.

 

Thinking it might be a Google security issue, because Filemaker's mail engine is reputedly slightly out of date, I logged into the account in Google and ensured we do not have 2-factor authentication configured and that we have already enabled "Allow less secure apps". The list of allowed "less secure apps" includes only an entry for "OS X" and another for "Synology" (our NAS). But there is no way to whitelist or create exceptions for additional applications.

 

I've also tried configuring the Gmail relay service, but that doesn't change the outcome either.

 

I know this is a FAQ but none of the suggestions I've found anywhere seem to make any difference. As an aside, I find it extremely annoying that Filemaker does not provide any support with the rather expensive licensing we pay for annually.

Outcomes