AnsweredAssumed Answered

Communication with the host was interrupted...

Question asked by dmmarti2 on Dec 15, 2017
Latest reply on Mar 13, 2018 by TSGal

Hello FileMaker Community,

 

I have a problem and I could use any expertise available to me in order to work this out. I contacted FileMaker about this and was told I would be sent an email with instructions but it never came, and there's no way for me to get back to the same person. I could not find any information in this community that matches my issue exactly. Here is some misc. information regarding our setup.

 

  • All employees access the database via VPN connection, all databases are password protected.
  • We are running the current release of FileMaker Server 16 and Filemaker Pro 16 clients, licensed.
  • All software is running off a private server that is 10x the performance needed for FMS to operate.

 

One of my employees started getting this Error Message yesterday afternoon (12/14/2017) while editing the layout, and it has not stopped popping up even today (12/15/2017):

 

Communication with the host was interrupted, files with uncommitted changes in layouts or scripts will be closed and these changes will be lost. Do you want to try to reconnect other files?

 

After receiving this message, he has the option to exit or reconnect. Reconnect option shuts down Filemaker anyway.

 

Here is what we have tried in order to narrow down the cause of this, as no information on the FileMaker website offered a solution:

  • I have personally logged into his account, made changes, saved with no issue with my computer.
  • I called FileMaker Support and was told if no other client machines are experiencing the problem, it is most likely his software or computer that was the issue. I was supposed to get an email with some solutions and never received it. He did however recommend reinstalling it so I at least accomplished that.
  • My employee has reinstalled FileMaker with no luck. He installed it on another employee's computer and got the Error again.
  • I've checked physical server logs, there has been no outages and the VPN connection is stable.
  • I've checked FileMaker server logs, and it shows all his disconnect warnings, but no helpful information on what is causing this issue.
  • This has only started happening within the last 24 hours or so, but not for me or anyone else.
  • I created a secondary Full Access account for him to see if maybe it was something to do with his original account, but he still got the error from both laptops ( his and the test employee computer )

 

The only thing I can think of it being is that both employees are using a mobile hotspot to access the internet. I'm not sure how or if this would even effect connecting to the server via VPN. As mentioned, it has worked all week with no issues until yesterday. I even watched via SKYPE Screenshare for this to occur, and there was no disconnect from his VPN connection software. We are currently testing a regular WiFi network, but as he is out of state I have to wait on news of this before moving on.

 

This particular employee is our development guru, he is the one person on the team who absolutely must have access to FileMaker and edit our database, as I am only responsible for running the server and user accounts and security.

 

I thank everyone for their input, it is greatly appreciated.

 

Many thanks,

D. Martin

Outcomes