AnsweredAssumed Answered

Slow response when entering into a field

Question asked by MikeMcErlean on Dec 20, 2017
Latest reply on Jan 3, 2018 by philmodjunk

I've an issue with very slow response when entering into a field, which just started recently.

 

I've got a client running Windows 7 for  FileMaker Server, FMP Advanced, and FMP, all in the 32 bit version.  Generally, the response time is quite good.

 

I have a field with radio buttons, a script trigger, and conditional formatting in a portal on one of the layouts.   On all windows client machines, entry into the field is painfully slow to the point of unusable, almost all the time. I say almost all the time, as occasionally couple of clicks will work as expected, then it goes back to glacier motion mode. There doesn't seem to be any pattern to it.

 

With the script debugger, I can tell that the script trigger isn't firing until the field's radio button has updated.  Just to check, I removed the script trigger, which didn't have any effect on the speed of entry into the field. I've also reindexed the files, replaced the value lists, tried other types of lists (popup menu, list) deleted and replaced the field, tested with and without conditional formatting. Lots of shutting down and restarting the machines. Nothing seems to make it any more consistent.

 

I believe this to be a Windows client version only issue, as it doesn't occur on a Mac client using the file on the same Windows server.

 

Can anyone shed any light on this for me?

Outcomes