AnsweredAssumed Answered

What has changed in SSL connectivity for the WPE between FMS 15 and FMS 16?

Question asked by douglerner on Dec 25, 2017
Latest reply on Dec 27, 2017 by douglerner

Here is an odd situation I'm running into in a new FMS 16 (OS X) installation I'm testing using the WPE making GET calls from my own server. My server is not PHP, not Apache, nor is it related to FileMaker. It's a different NoSQL object-oriented database-based server that runs a social network and is making WPE calls to FMS to update records and things like that.

 

All the URLs in each case below are the same (looking up a record-id). When it works it returns valid XML. When it doesn't work, it returns a "* Connection error: 1590".

 

With FMS 15 (Windows)

  • from our server with http - works
  • from our server with https - works
  • with Chrome from my Mac with http - works
  • with Chrome from my Mac with https - works
  • with curl from our server's Linux shell with http - works
  • with curl from our server's Linux shell with https - works

 

With FMS 16 (OS X)

  • from our server with http - works
  • from our server with https - doesn't work: returns * Connection error: 1590
  • with Chrome from my Mac with http - works
  • with Chrome from my Mac with https - works
  • with curl from our server's Linux shell with http - works
  • with curl from our server's Linux shell with https - works

 

So there is some compatibility difference between FMS 16 (OS X) vs FMS 15 (Windows) and our server when making WPE GET requests, but only for https, not for http.

 

So I wonder if the https connectivity requirements have changed between FMS 15 and FMS 16 and if that is something I can tweak in the FMS 16 admin console.

 

Thanks,

 

doug

Outcomes