AnsweredAssumed Answered

Trouble playing videos in interactive container fields

Question asked by pm125 on Dec 26, 2017
Latest reply on Dec 26, 2017 by ChrisJohnston

Hello everyone, Having trouble playing videos in interactive container fields.

 

I have a database of video clips on a machine running server. The clips are inserted as video clips (Insert Audio/video) into a container that is optimized for interactive media. For a few days I could not figure out why the videos played in some machines and not in others (they showed "Error" where the Play icon should be). Thanks to Google I learned of other people's valiant efforts (I had not yet re-joined the FM Community forum). The answer was:

 

This arrangement does not work with SSL turned on, at least not using the SSL certificate that comes with FM Server and that is meant for testing (which is exactly what I am doing). I have three questions:

 

- When SSL was still turned on, why did the videos play on some computers and not on others?

 

- If I purchase a commercial SSL certificate, is there a chance the videos will play?

 

- If not, does anyone know of a method to serve a video database using SSL?

 

Here are details:

 

- FM server 16.02 (or whatever the latest update is as of 12/23/17) running on a Mac Mini (~20014) with an i7 processor on OS X Sierra (10.12.6, latest update but not the latest OS High Sierra).

 

- FM Pro 16.02 clients (or whatever the latest update is as of 12/23/17) and 15.01 clients running on 2016 Macbook Air, 2016 Macbook Pro, 2017 iMac i5 processor, 2013 Macbook Air i7.

 

- Database is accessed both within a campus network (authentication only through Filemaker; no interaction with Windows or other authentication process), or from home via a VPN connection.

 

- There was no obvious pattern in which systems could play the videos and which could not. Some of the FM 15 clients played them, while others did not, and some of the FM16 clients did and others did not.

 

- I think all processors were 64-bit, which made me suspect the problem might be one of missing codecs (see this comment from Filemaker: FileMaker Pro 16 Help

 

" In some cases, the 64-bit versions of the audio and video codec software required to play some files in the 64-bit version of FileMaker Pro may not be available."

 

However, I tried different formats without any effects: the machines that played videos played all formats including MPEG2, while the ones that did not work could not play a modern H.264 video in a MOV wrapper.

 

- Notably, the machines that could not play videos allowed exporting the video file from the container, and the exported videos played normally using Quicktime outside of Filemaker.

 

- I tried all 3 ways of storing the container field's data: in the database, externally, and externally securely. This made no difference.

 

Any suggestions are welcome.

 

Best regards,

 

Pietro

St. Louis

Outcomes