AnsweredAssumed Answered

FM Server Admin Console user/password half broken?

Question asked by justinc on Jan 24, 2018
Latest reply on Jan 24, 2018 by justinc

I ran into an odd problem just today.  On an installation of FMServer 15.03 (running on Windows 2012 R2) I am not able to successfully connect to it for uploading a new file to the host.  I have tried many times, both using stored credentials as well as typing/copying/pasting.  However, I AM able to successfully log into the Admin Console using the same credentials.  There is a note in the Log file that my client failed login trying to do an upload.  I don't know how long this might have been going on; files are uploaded to this server rarely, and since logging into the Admin Console still works it was never noticed as a problem.

 

Oddly, when I log into the Admin Console and go to "General Settings -> Admin Console", the current Username for the console is empty.  So, even if I wanted to reset/change the UN/PW, I can't do it because it can't authenticate the current user.  But the current user works - I am able to log into the Admin Console from both a remote computer (mine) and a browser on the server itself.

 

I removed the host definition from my client and recreated it (so it wouldn't have a stored UN/PW):  failed login

I have stopped/restarted the Admin Console process (the slider button on the Admin Console itself):  failed login

I have stopped/restarted the OS Service process (Windows -> Services -> FileMaker Service):  failed login

I have restarted the entire server (fortunately this is a developer machine):  failed login

 

But, through all of these cases (I tested this at each of the above states):

Logging into Admin Console from remote machine (using saved or hand-typed UN/PW):  success

Logging into Admin console from browser running on server directly:  success

 

Anyone have any ideas of what's up with this?  Or how to fix it?

Outcomes