electric_soul

Filemaker 16 is not using the systems keyboard layout.

Discussion created by electric_soul on Feb 9, 2018
Latest reply on Feb 13, 2018 by TSGal

Hello

 

 

Product and version

Filemaker 16.x Pro/Adv

 

 

OS and version

Win 7/10

 

 

Description

Filemakers hotkeys keyboard mappings are depended on the chosen "user interface language". Therefore we cannot use some hotkeys, if we develop in english. And developing in english is a must nowadays.

 

Example for "Disable Script step" in the script editor.

English language: CTRL+/

German Language: CTRL+SHIFT+/

 

 

How to replicate

Change the "user interface language" from english to german at "edit > preferences > user interface language" and try the hotkeys in the description above.

 

 

Workaround

none....    or not using some hotkeys

 

Possible solution

Filemakers hotkeys keyboard mappings, must depend on the systems keyboard layout

 

Hint

Now I assume Filemaker has intended that, but this is such a bad design decision that basically breaks all rules that I call it a bug rather than a bad feature

Outcomes