mattb

FMP Mac Runtime issues

Discussion created by mattb on Apr 3, 2018
Latest reply on Apr 4, 2018 by schamblee

I have a commercial app developed in FMP 12 on Mac a few years ago and distributed in Runtime format so that customers don't have to actually own a copy of FMP.  It's been running fine until this year - with the release of OSX 10.13.xx (High Sierra), some unexpected crashing issues developed. 

 

I made a new test Runtime version based on FMP 14 and those crashing problems seem to have disappeared, so on this score - problem solved.

 

But...since this is a commercial program with customers out there who have been working on the older version, and who will wish to use the new version with their older data, a new problem develops.  I know both FMP12 and FMP14

files have the same data format (.fmp12 originally), but when the Runtime is created, files are bound to a particular Runtime app and will not open under the newer Runtime.  I get the following message:  "This file cannot be opened because it does not belong to this solution".

 

How can this be worked around?  Is there some way to re-associate an older data file created under FMP 12 Runtime to now be associated with an FMP 14 Runtime??  After all, the data formats are identical and FMP 14 itself can open these files, just not the new Runtime...

 

Matt Bloomfield

matt.bloomfield@gmail.com

Outcomes