AnsweredAssumed Answered

Says script has been deleted, then performs script

Question asked by annd on Apr 12, 2018
Latest reply on Apr 12, 2018 by philmodjunk

I am pretty new to all of this, and I am flipping out a wee bit about my database.

 

Yesterday, a checkbox started glitching, which is to say, whether I selected it or deselected it, it retained the value as if it had been checked.  I deleted the field, added it again, and had it perform the same script.  It worked fine.

 

Today, it counted the same attorney twice - and listened his name twice - but only on one client record.  On other client records, the same attorney, assigned in the same manner, was counted once and appeared once.  I spent 90 minutes trying to figure that out before just deleting the client and re-adding him, which fixed the problem.

 

As soon as that problem was fixed, one particular layout started acting possessed.  If you click a button, it says the script has been deleted, then performs the script perfectly.  If I change to layout mode, it gives me the same script warning (there are NO active triggers on the layout).  If I click the Manage Database button, I get the script warning again.

 

The script where I first noticed the problem is not calling any sub-scripts.  It's simply setting fields.

 

 

It has the same reaction now when I click another button on the same layout and perform a different (but equally simple and straightforward) script.

 

I went through the recovery process, and it said it found zero problems.  There are clearly problems.  I can re-build the layout, but I don't know what I did to cause this, and I'm kind of freaked.  My go-live date is May 3.  The problem checkbox from yesterday was on a different layout.

 

Help???

Outcomes