AnsweredAssumed Answered

Export Records changes data in first record.

Question asked by PaulSeabright on May 8, 2018
Latest reply on May 9, 2018 by beverly

I have a simple table that I have been successfully exporting to a csv text file.  The first record has the field names written to it.

 

When I run the export (from the file menu or from within a script), there is a field in the first record that consistently and repeatedly changes what ever is in that field to a 0.  e.g. export changes 'Qty' to '0'.

 

I have tried different Output file Character sets, recreating the data in FMP and closing & opening the file - all to no avail.

 

The only change that has been made to the file, is to change the data type for that field from text to number as I want to use sum summary on the qty field.

 

By accident, I created a tab delimited output file that did not change the 'Qty' to a '0'....

 

Does anyone have an insight as to why this is happening?

 

OK, I found the fix!

 

By selecting the tick-box (bottom left of the 'Specify Field Order for Export' window)  "Apply current layouts data formatting to exported data" the issue is resolved.  I think when I first saw this, I read it as referring to text formatting, though that doesn't really explain why it only happened with a csv file and not a tab delimited file does it?

Outcomes