AnsweredAssumed Answered

Scripting Import - 'Don't import first record' option not saving

Question asked by fmdataweb on May 8, 2018
Latest reply on May 8, 2018 by ThierryGuemboura

I'm trying to setup a scripted import of a .csv file that users will need to import from time to time to add new records - we don't want to import the first row as that contains the field names, so in the simple script I've setup I have selected the 'Don't import first record' option in the Import Field Mapping dialog box.

 

When setting up the script and test I added the file path to the .csv file I was testing with and everything worked fine. I then went back to the script and unticked the 'Specify data source' option for the Import Records script step as each user will be importing their own .csv files in the future which will be stored in various locations on their PC with different file names, so I can't hard code the path to the .csv file.

 

Now when I look at the Import Records script step the 'Don't import first record' option has been deselected and the first row is being imported which we don't want. My question is: is it possible to store the import order and the 'Don't import first record' option in a script with no file path to allow users to select a .csv file when importing?

Outcomes