hickam

Record Locking Via Privilege Sets

Discussion created by hickam on May 17, 2018
Latest reply on May 20, 2018 by BruceHerbach

I showed this problem to another developer who could not help and I could find nothing on the web and nothing in the Knowledge Base regarding the following issue.

So, I called filemaker customer support and was told "we do not support filemaker development" and that I should "play around with it..."

I am speechless...

 

Here is my problem:

I have a calculation in the record access Edit Limited feature of a privilege set. It locks records in a table based on a calculation. Records can or can not be edited based on the calculation criteria.

In testing this works as desired when fields for the given table are on the layout. I can't edit them. But when setting the same fields via a script, error 200 occurs intermittently. Sometimes the field is set with a value, sometimes a field is not accessible by the script.

I have checked field type and field options. There is no difference between the fields that have access and those that don't. They are all in the same table and when I place the the same fields on the layout and try to manually edit them, they all correctly have no access.

I have tried running the script with Allow User Abort Off and On.

I have tried running the script with Set Error Capture Off and On.

The script is not set to Full Access.

 

Anybody experience this? Have a solution?

Outcomes