AnsweredAssumed Answered

IOS Plugin, SDK 17

Question asked by sfpx on May 22, 2018
Latest reply on May 22, 2018 by sfpx

I have an app with a custom plugin that works fine with the sdk 16

I converted it to use the sdk 17.

The app is running fine but the plugin does not load

I get a "required code signature missing" error when the app is launching.

I tried many things for hours without any success

-Deleted the derived data folder, cleaned and rebuilt many times

-Signed the plugin (not sure it actually worked though)

-Tried the demo plugin (same error)

-Deleted my certificates

-Tried to simply replace the sdk16 framework by the sdk17 framework in my project that was working...no success.

 

etc

 

Now, I will admit that I'm still using xcode 8 which is not supported (I can't upgrade to xcode 9 yet because my mac is too old for Sierra) but I still was able to get the sdk16 and the plugin to work on xcode 8 even though it was also below the requirements.

 

So anything changed in the sdk17 regarding ios plugin installation ?

Outcomes