bablackburn

Phantom Record?

Discussion created by bablackburn on May 29, 2018
Latest reply on May 29, 2018 by bablackburn


This one has me going completely mad. A user reported an issue where when trying to navigate to a related record they were being sent to the wrong record. I checked the script and everything seemed in order so I tried to replicate the problem and sure enough when trying to go from employee BF1's info page to their tool allowance page it would instead take me to employee CB1's tool allowance. This only happens to employee BF1. When I went to check if the record was still there it is with nothing out of the ordinary. However if I search for employee BF1's tool allowance it shows up with TWO records. One is completely blank, the other is the standard record. When I try to delete the blank record the total record count remains unchanged and upon another search for BF1 it reappears.

 

I tried simply deleting both records and remaking BF1's tool allowance but it then says that the unique value is already used and to use a different ID.

 

I am completely lost as to how any of this is possible.

Outcomes