AnsweredAssumed Answered

FMS 17 disappearing Local server - bug?

Question asked by VetturaLogic on Jun 8, 2018
Latest reply on Jun 11, 2018 by BillMiller

Hi All,

I'm seeing some strange behaviour in FM 17 that's confusing me and wondered if it was my setup or a possible bug.

 

I have FMS 17 installed on a Mac mini, in a small office network, accessible to 4 users using Windows 10 and myself on Mac OSX. After setting up the server last week and installing FM 17 on everyone's computers, we all successfully accessed the served files within the office network and could also reach them remotely when outside the office network. We moved to this setup from a peer-to-peer sharing deployment in FileMaker Pro 12.

 

I was about to install an SSL Certificate today week but a couple of the Windows users have had trouble accessing the served files. Sometimes they see "Connection Failed" when selecting the server address they have previously saved to Favourite Hosts and, while within the office network, they don't see the Local Server showing at all, so are unable to select and open the served files. When this is reported, I personally can see the Local Server showing on my Mac and also available in FileMaker Go 17 on iPhone & iPad but not on the Windows machines.

 

I thought this might be an SSL issue at first but decided to create a test environment to check what was happening, as follows:

 

My Test Server:

Mac mini - OS X 10.13.5 - FMS 17.0.1.146

 

Network Devices

1. Microsoft Surface Pro - Windows 10 Pro v1803 (build 17134.81) - FM 17.0.1.143

2. MacBook Air - OS X 10.13.5 - FM 17.0.1.143

3. iPhone 6 - iOS 12.0 - FMGo 17.0.2

4. iPad Air - iOS 11.4 - FMGo 17.0.2

 

On both the iOS devices and the MacBook I always see the served sample file available, with the test server (Chilterns-Server) displayed in the "Local" list.

 

MacOSX.jpeg

 

 

However, on Windows 10, the Local server just isn't showing any servers available under "Local".

 

Capture4.JPG

 

I can get round this by directly entering and saving the server's IP address as a Favourite and then the sample file will show...

 

Capture3.JPG

 

but the next time I open with File > Hosts or File > Open and select Hosts, although my saved IP still shows in Favourites, no files show as available and I get the "Connection failed." message.

 

Capture.JPG

 

When this shows as "Connection failed" I can still the sample file in Local hosts on iOS and OS X machines.

 

Interestingly, the first time I'd successfully opened the sample file I saved it to My Apps. So, with no Local server showing available and with "Connection failed" showing for my Favourite IP, using the icon in My Apps successfully opens it!

 

Capture2.JPG

 

 

NOTE: I'm only seeing this behaviour on the Windows machines, my Mac and any iOS devices on the network work as expected, with the Local server showing every time.

 

Is there something new I should be doing with Windows and served files in FM 17 or might this be a bug particular to FM 17 for Windows?

 

Incidentally, I've also tried using a launch file, with the Open File script to open the served sample file and this again works fine in OS X but fails to open on Windows 10.

 

I've also tried peer-to-peering a file from both Mac and Windows devices and, again, the peer-to-peer file shows in the Local hosts list on Mac (shared from the Windows machine) but when shared from the Mac, it doesn't show in the Local hosts on the Windows machine. it's as if FM 17 for Windows can see a Local host but it's not displaying it to the user in the Hosts pane.

 

 

Any suggestions please? 

Outcomes