AnsweredAssumed Answered

Trying to install a v16 SSL Cert after initial failure

Question asked by philmodjunk on Jun 21, 2018
Latest reply on Jun 27, 2018 by fmpdude

OK,

 

I've installed a certificate on one server and it worked exactly as it should, no problems.

 

But now I'm setting up another server and have gotten failures each time I've tried.

 

Time to start all over after the initial failure.

 

Are there files in Cstore or elsewhere that should be deleted before I generate a new CSR?

 

I want to rule out all possible issues when I try again.

 

And since a coworker is taking the CSR and generating a GoDaddy certificate, I need to check to see if I'm even getting the right things.

 

The knowledge base article on doing this found here: https://support.filemaker.com/s/answerview?language=en_US&anum=14176#concatenate

 

States:

After the purchase, you will receive an email from the CA containing your server certificate (yourDomainName.crt) along with addional root and intermediate certificates. The certificate should be in Base64 PEM format. Common extensions are .pem, .crt, or .cer. Since only one intermediate file can be specified during import, the root and intermediate certificates must be concatenated into a single .pem file.

Open each root and intermediate certificate in a text editor, then copy and paste the contents into a single file named "chain.pem". The certificates should be pasted in hierarchical order, starting with the root certificate at the top.

But the last failed set of certificates had two files and neither had the domainName as the file name. My coworker insisted that the file named:  fdc27f67e3ff9d22 was the server certificate. Can this be correct? The difference between what was delivered and what I read in the KB article leaves me wondering.

 

And there was no "root certificate" only an intermediate certificate. So was I supposed to just specify the intermediate certificate and it was supposed to work.

 

This all may come down to me using the wrong encryption key due to an error on my part, but I need to rule out other possible issues before I try again.

Outcomes