AnsweredAssumed Answered

Diagnosing Error Messages when installing SSL

Question asked by philmodjunk on Jun 26, 2018
Latest reply on Jun 27, 2018 by fmpdude

While importing certificates on the second FMS 16 server for which I've needed to do this, I realized that I was getting different error messages that were trying to help me diagnosis the error. Has anyone tried to document these error messages and provide corresponding corrective action options for each?

 

What I noticed was that if I typed in the wrong decryption key or had the wrong copy of the key file selected for import, I got an error message telling me that the files couldn't be decrypted. Obviously, getting the right file selected and typing the right key in are the steps to take to correct this. (I now type my key into a FileMaker file's text field, then copy paste it into right blanks when getting the needed request. When it comes time to import the certificate, I go back to that record and field and copy/paste from it to get it right.)

 

But if something else was going wrong, the key would be accepted, but I'd get a message that Filemaker couldn't validate the certificate (or some words to that effect). In this case, it would be a case of making sure that the domain name specified in the certificate (which is supposed to match the one in the CSR) matches the one used while importing certificate files. Again, maybe saving the exact text in a text field in FileMaker and using copy/paste might avoid a few pitfalls.

 

I now wish that I'd captured screen shots of each error message for documentation/training purposes and there may be other error messages that I didn't see popup as I avoided making those errors.

 

So I'm wondering if any one has tried to build a list of these messages that can then be used as a community resource for others struggling with the needed installation process?

Outcomes