nathanjames

**SOLVED** Certificate could not be imported: The Certificate file is not valid.

Discussion created by nathanjames on Jun 27, 2018

I was having the most difficult time figuring this out and the solution was MUCH easier than I thought.

 

Hosting: AWS EC2

OS: Windows Server 2012 R2

Filemaker Server 16

 

I received my certificate from GeoTrust. The request and issuing of the cert went fine. When I went to install the cert into FileMaker server 16 I kept getting this error message: "Certificate could not be imported: The Certificate file is not valid."

 

When I downloaded the signed certificate they give you the option of which platform and OS you are installing to. I selected Windows 2012 IIS 8.0 & 8.5 to match the server setup. THIS is what caused my problem. It sent me a PKCS #7 Certificate file with a .p7b extension which should deploy into the server itself with no problem but for FileMaker this will not work.

 

Here is what I did:

 

When I downloaded the cert from GeoTrust's website I selected "Other" as the platform and X509 as the format rather than selecting Windows 2012 IIS. So this way the download contained the signed certificate with the  .cer extension and the intermediate file as well. When I entered these into FileMaker Server it worked right away.

Outcomes