AnsweredAssumed Answered

Connection lost when using PSOS from FMPA 17 to FMS 17 on the same machine

Question asked by HOnza on Jun 30, 2018
Latest reply on Aug 6, 2018 by HOnza

When testing something else, I accidentally discovered this issue:

 

Product and version: FileMaker Server 17v1

OS and version: macOS Sierra 10.12.6

Hardware: MacBook Pro (15-inch, Mid 2012)

 

Description:

Script A runs Re-Login with invalid credentials in a loop for 10 seconds.

Script B performs script A on server without waiting for result, and does that in a loop for 30 seconds.

After Script B finishes running, the database still appears functional for about a minute, but in fact the connection between the client and the server is lost. After some time the "Client no longer responding; connection closed. (10)" message appears in Event.log.

 

How to replicate:

Upload the attached test database to server and open it.

Then open it using FMPA (name admin, password 123456), and click on the "Run on Server" button.

Keep working with the database until you see a prompt to re-connect.

 

I would not consider this issue serious, but I often use Re-Login as an easy way to log debug information in the Event.log when debugging server-side scripts, so I am wondering what's behind this issue and whether I should consider the Re-Login logging technique dangerous in some specific circumstances.

 

Update: I have just discovered this happens with even just single use of Perform Script On Server when connecting from FileMaker Pro 17 Advanced to FileMaker Server 17 running on the same machine.

When I try connect from a different device, or from FileMaker Pro 16 Advanced on the same machine, the connection remains stable.

Attachments

Outcomes