AnsweredAssumed Answered

Pop-up menu incorrectly shows first field

Question asked by Jason Wood on Jul 3, 2018
Latest reply on Jul 5, 2018 by jbrown

Product and version: FileMaker Pro Advanced 16 & 17

OS and version: MacOS High Sierra 10.13.4

 

Description

 

In FileMaker 16 & 17, when you add a new field to the layout and then set it as a "Pop-up Menu", and then select a value list where "show only values from second field" is enabled, when you return to browse mode you will find that only the first field value (usually the id) shows in the field (note: while the popup menu is open, the second field values correctly display).

 

Workarounds:

 

To fix the problem after it has occurred:

Change the control style to "Edit Box" and then change it back to "Pop-up Menu".

 

To avoid the problem from happening in the first place:

The key is that the value list must be selected before selecting "Pop-up Menu", which means you need to select another control style first, then select the value list, then select Pop-up Menu. If you already selected Pop-up Menu and the value list, simply change to any other control style and then back to Pop-up Menu.

...or use FileMaker 14 ;-)

 

Additional Information:

 

Opening the file in FileMaker 14 (I don't have 15), the fault displays on fields created in 16/17 but cannot be recreated by adding a new field.

 

I tested this on a newly created file and I tested with 2 themes. Then I created a brand new file on a second computer and I had the same result but I noticed a little extra weirdness... Any newly defined fields that are automatically added to current layout will not exhibit the problem behaviour when you add the pop-up control style.

 

It does not matter if the field contains a value while it is added to the layout.

 

Here's a screen shot to illustrate:

 

Screenshot 2018-07-03 23.10.48.png

Outcomes