l_allen_poole

Misleading outcome when switching container storage fails

Discussion created by l_allen_poole on Jul 4, 2018
Latest reply on Jul 5, 2018 by l_allen_poole

FMP 16 connecting to a FM 16 server running on MacOS 10.13.

 

I've got a c. 950MB file with one container field with open external storage and about 35k documents (about 26GB) in this external storage. Today I tried to bring those documents back into the FileMaker file by switching the container fields's storage definition from external storage to internal storage. After "Estimating disk space requirements" for a while, a "Transferring container field data" progress bar told me the data was being transferred... and at the end of all this a "Transfer summary" dialog said the process had failed. The log file detailed how every record's container data failed validation with error 507 and 0 records' data  had been transferred.

BUT

in the table's field definitions the container field's storage setting now show internal storage, not external storage. My documents are all still visible in the UI and the size calc. field correctly displays each one's size, but the file size hasn't changed. If I rename the external container storage folder, all documents vanish from my UI, and when I rename the folder back to what it should be they reappear. Seems clear that the field is still using external storage, even though it says internal.

When I go to switch it back to external storage, I get the same process described above, the same error message at the end, and as before the field's storage setting has changed even though no data transfer actually happened.

 

If the data transfer fails and the de-facto container storage doesn't change, shouldn't the field definition reflect these facts and also remain unchanged?

Outcomes