AnsweredAssumed Answered

Web publishing not really on, only on localhost, pboard issue

Question asked by Vincent_L on Jul 5, 2018
Latest reply on Jul 5, 2018 by Vincent_L

Hi,

 

I'm FMS 16.0.3 on Sierra 10.12.6. I've the web publishing set up :

I don't use it much, just launch FileMaker script via URL, and launch one PHP script or two.

It worked great until this morning. I didn't change anything.

 

I can go to FileMaker web admin GUI, but only on localhost 127.0.0.1.

If I try from another machine on the same LAN, it doesn't work. Like if the URL didn't work.

It's not just a FileMaker webadmin issue, it's also my simple PHP scripts that don't work anymore (nor on localhost).

 

In FMS Admin I can see that the web publishing is green but Web server is greyed out. If I try to click on PHP or XML, I received the message stating that web publishing must be launched. But just below it's green

 

 

Photo Partage d’écran, 5 juillet 2018 à 11.53.57 UTC+2.png

 

I tried to restart the WPE service, restart the computer, nothing.

While starting WPE with fmsadmin, I looked t the console and saw this :

 

fmscwpcConnection to 'pboard' server had an error: <error: 0x7fffa1e09ca0> { count = 1, transaction: 0, voucher = 0x0, contents =
"XPCErrorDescription" => <string: 0x7fffa1e09f18> { length = 18, contents = "Connection invalid" }
fmscwpcFailed to obtain 'pboard' service port: <error: 0x7fffa1e09ca0> { count = 1, transaction: 0, voucher = 0x0, contents =
"XPCErrorDescription" => <string: 0x7fffa1e09f18> { length = 18, contents = "Connection invalid" }
fmscwpcfailed to create global data

 

 

Any idea to fix it.

Outcomes