AnsweredAssumed Answered

Excel truncating large numbers when opening .csv or .xlsx

Question asked by CordegaSolutions on Jul 9, 2018
Latest reply on Jul 12, 2018 by CordegaSolutions

Hi.  In FileMaker 16 and 17, if I export fields that have numbers with 41 digits to .xlsx or .csv files, when I open the data up in Excel, it's only capturing the first 15 digits, and then the rest of the digits have been converted to all zeros.

 

This happens whether we use the Export Records feature or the Save Records as Excel function, or save the records in a .csv format.  Note that if I open the .csv file in notepad, the full 41 digit number *is* there.  So I think it's an issue with how Excel is truncating the number upon opening the file.

 

This is going to be a HUGE problem for us, because we are using these 41 digit numbers as unique IDs.  And folks export data to Excel all the time, and we'll need those numbers to match when importing/updating data back in.

 

Can anyone shed some light on how we might get around this?  Is there a specific Excel setting we need to implement?

Outcomes