AnsweredAssumed Answered

Printer Settings using FileMaker

Question asked by adept-systems on Jul 16, 2018
Latest reply on Jul 16, 2018 by philmodjunk

Hi there,

 

I am having a little issue with code for a label printer that is set up. To let you know my issue I’ll go through what is supposed to happen and give a bit of detail around about the system we use. We use FileMaker to print off the labels using a label printer which has always worked until recently, I have checked the settings for the printer and made sure the sensor is transmissive which without can cause labels to come out wrong, I have saved the settings in this software fine. When it comes to running the script, I have made the settings pop up so we can have a look at the settings to make sure nothing is wrong or shouldn’t be as it is and the sensor is set to none. I have double checked my work and even had a separate pair of eyes to help me though this and it still will not bring up the sensor. I know the issue is that the sensor settings is not being transferred, I just don't know how to fix this.

 

Code I am using for printer setup:

Print [Restore: \\PR-DESKTOP003.PlantRaisers.local\TEC B-SA4T (300 dpi) With dialog:On]

 

In here I set the printer properties that allows me to be able to use specific labels/sizes on different scripts including the sensor.

 

Edit:

The printer we have is a Toshiba TEC SA4T Label Printer, we have two and we have switched them around to see if it still encounters the same error.

 

When running through script debugger I get the same issue, runs though the code fine and brings up the printer prompt but still no sensor attached.

 

We have recently had to move this computer to another room but no no changes have been made recently to the system that could've affected this apart from me checking to see if the code is current and correct for their various printers.

 

We have another printer the same make and model and it encounters the same issue where it has defaulted the sensor to default.

 

I have turned the sensor type to all the sensors as you cannot remove the sensor check step but it still defaults back to none.

Attachments

Outcomes