AnsweredAssumed Answered

Can I export to .xlsx or .dbf from WebDirect?

Question asked by ui_appdev on Jul 16, 2018
Latest reply on Jul 17, 2018 by TSGal

Product and version: FileMaker WebDirect accessing a solution hosted on a Windows 2008 R2 SP1 server running FileMaker Server 16.0.3.304

Browser and version (for WebDirect only): Chrome 67.0.3396.99

Client computer(s): Dell Optiplex 9000 series

Description:

(tl;dr): exporting to either .dbf or .xlsx from WebDirect does not work.  why?

 

I have written a script that will export all records from a particular table (let's call it T01_my_table).  The script first checks for the SystemPlatform.  If the platform is not iOS and not WebDirect, the script creates a filepath for an .xlsx file (Get ( DocumentsPath) & "a_custom_string" & ".xlsx").  If the platform IS WebDirect, the script creates a filepath for a .dbf file (same as previous, except ending in ".dbf").  Then, the script navigates to a layout I have created that shows records from the T01_my_table table occurrence.  I use the "Show All Records" script step, and then, if not in WebDirect or iOS, exports to the filepath and automatically opens the file.  This works perfectly.  If the user is connected via WebDirect, on the other hand, the script does not seem to generate the file.  The script appears to run without error, as I am trapping for errors after the "Export Records" script step, and showing a custom dialog if there is an error.  At the time of development (March 2018), this worked, but as of May, it stopped working.

 

 

I have tried to change the filepath and file type to .xlsx, but then I receive an error from WebDirect that says "File could not be created on this disk. Use a different name, make more room on the disk, unlock it or use a different disk."  If I change the filepath/file type to .tab, .csv, or .mer, the file generates without issue.  However, the .tab format does not retain field/column names, and my client is not able to easily parse the comma separated values from the .csv and .mer files because one of the fields contains text entered by users that may contain commas.

 

 

There are a few workarounds I am currently employing, but they are not ideal.  I would like to know if there's something I need to be doing differently in order for the .dbf export from WebDirect to work again, or if there's something I can do to make the .xlsx export from WebDirect work at all?  Or if this is a known issue that I won't be able to solve without a workaround?

Outcomes