AnsweredAssumed Answered

Serious problem with IOSAppSDK 17.0.2

Question asked by driedle on Jul 23, 2018
Latest reply on Jul 26, 2018 by driedle

Well, I have a problem with the IOSAppSDK 17.0.2. I redesigned a database for use with FileMaker 17 for use with FileMaker Go 17.

 

I was elated when FileMaker 17 allowed you to attach more than one attachment to an e-mail. This was something my beta testers had requested for more than a year.

 

Finally!

 

I went in and basically re-designed the database with the new capability. I went in and cleaned everything up, developed new video demonstrations, etc.

 

Everything was working swimmingly. It worked great in FileMaker Go17, and I was quite happy.

 

The problems started when I tried to use the IOSAppSDK 17.01. After running the SDK, my solution would lock up every time when I started the app when it was starting up just after it got to the launch image.

 

I did a bit of research, and developers had indicated that they had problems with the launch image. I had never had this issue before, but I removed the launch image. The app locked up in the exact same place without the launch image.

 

To determine if it was being caused by my IOS devices, I attempted to run it in the simulator for IOS 11.4. No joy.

 

I attempted to run it in the simulator for IOS 11.3. No joy.

 

I read of a lot of people complaining about Xcode 9.4.1 and wondered if it might be an Xcode issue, so I uninstalled it and installed Xcode 9.3.1. I ran the IOSAppSDK 17.0.2 again, and saw the same problem, and even worse, I could not use it with any of my devices because they were all IOS 11.4.

 

Extremely frustrated, I researched the problem for another couple of days, and nothing worked.

 

At the end of my rope, I suddenly wondered if it could be a problem with the IOSAppSDK.

 

I downloaded the IOSAppSDK 16.0.4, and installed it. I ran it without the launch image. It worked perfectly in the simulator.

 

I added the launch image, and ran it again from the IOSAppSDK 16.0.4 with the launch image, and it ran perfectly in the simulator. My issue was not being caused by my launch image.

 

I ran it again, and installed it on my new iPad, and it worked perfectly.

 

I ran it again, but from the IOSAppSDK 17.0.2 in the simulator, and it crashed at the same point.

 

If it runs in IOSAppSDK 16.0.4, but will not run in IOSAppSDK 17.0.2, I would have to surmise that the issue is being caused by IOSAppSDK 17.0.2.

 

I REALLY want to use FileMaker 17, because of the ability to attach multiple files to a single e-mail.

 

Anyone have any suggestions?

 

David Riedle

Outcomes