AnsweredAssumed Answered

FMS17 Admin Console: "Service Unavailable" and "Error 503"

Question asked by DavidThorp on Aug 1, 2018
Latest reply on Aug 3, 2018 by tsplatypus

I'm finding FMS17 to be infuriatingly impossible to use.

 

Trying to open the FMS17 Admin Console. Nearly every other day I get this:

 

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

 

Sometimes reinstalling Java fixes it.  Sometimes I have to entirely reinstall FileMaker Server.  Then it works for a while and then this message comes back again the next day or some other time later.

 

This is happening pretty consistently on two separate FileMaker Server installations I have.  When it happens I get it whether connecting from the same machine (localhost/...) or another machine (10.0.1.240/...).

 

It may or may not be related, but sometimes when I don't get the above, I instead get either "can't connect to the server" or "can't establish a secure connection to the server" depending on whether I'm trying to use http or https, respectively.

 

#1: 2017 15" MacBook Pro maxed out (3.1GHz i7/16GB/2TB)

#2: 2014 11" MacBook Air (1.4GHz i5/4GB/128GB)

both running macOS 10.13.6 and FileMaker Server 17.0.2

 

I wouldn't say it's happening consistently because it sometimes works, so it's intermittent, but I'd say it's very regularly/very often, not just a rare occurrence.  I have not yet had a positive experience with FMS17 in pretty much any form for more than a day at a time, despite trying for at least two weeks.

 

Other info:

  • Tried with Java 8 Updates 171 (the officially supported one, installed by FMS17.0.2) and 181 (the current/latest one).
  • The files are hosted and can be reached by FMPA via "Open Remote..."
  • The command line (fmsadmin) responds properly to most commands (haven't tried all) but start or restart adminserver gives "Error: 10007 (Requested object does not exist)".
  • Not sure if this matters, but the processes running (viewed in Activity Viewer) are: fmserver_helperd, fmsased, fmsib, fmslogtrimmer, fmserverd.  If memory serves me correctly these are the same processes as when everything is working.  I don't recall any missing ones here.

 

In short, everything seems to be working except the admin console, from anywhere, including localhost.

 

I'd very much welcome, and appreciate any insights on what the heck is going on here and why.  (Or FMI to fix it if it's a bug).

 

 

EDIT/UPDATE, 8/2, 5am CDT.  Console log has a whole lot of entries saying:

 

2018-08-02 04:52:43.480 -0500

Information

703

Starting Admin Server process...

2018-08-02 04:52:43.511 -0500

Error   

701

Admin Server process has terminated abnormally.

2018-08-02 04:53:48.195 -0500

Information

703

Starting Admin Server process...

2018-08-02 04:53:48.226 -0500

Error   

701

Admin Server process has terminated abnormally.

2018-08-02 04:54:53.266 -0500

Information

703

Starting Admin Server process...

2018-08-02 04:54:53.298 -0500

Error   

701

Admin Server process has terminated abnormally.

 

Seems the problem is ... well ... "Admin Server process has terminated abnormally."  ... less than 50 microseconds (literally) after it starts.

 

What could be causing this?

 

 

EDIT/UPDATE, 8/3, 11am CDT.  I've now posted this as a product issue here: FMS17 Admin Console: "Service Unavailable" and "Error 503"

Outcomes