AnsweredAssumed Answered

FMP 16 cURL not working "102-Field Missing"

Question asked by user2148128 on Aug 8, 2018
Latest reply on Aug 8, 2018 by user2148128

I've been messing with this syntax for a "while" now and am having trouble finding out why it's not working.

 

Although MBS works fine with the same basic information, I can't get FMP 16's cURL syntax to work. In particular, one error I'm getting in the debugger is "102 Field Missing". No idea what this is complaining about. All the fields are on this single testing layout.

 

However, when executing this INSERT FROM URL command, nothing happens, other then the error.

 

Other things tried:

 

(1) I can, in the debugger, take the created URL and execute it directly in POSTMAN. No problems.

(2) MBS ... No problems.

(3) Tried creating a single variable for POST fields and referencing that from "-data".

 

-----------

 

So, what am I doing wrong with this cURL native syntax in FMP 16?

 

Baffling.

 

Thanks in advance,

 

Here are my cURL options:

 

"-X POST " &

"--header \"Content-Type: text/plain\"" &

"-data document=" & GetAsURLEncoded(Base64Encode(layout1::document)) & "&userName=" & layout1::userName & "&uuid=" & layout1::UUID & "&password=" & layout1::token

Outcomes