AnsweredAssumed Answered

UniqueValues function fails to return some unique values

Question asked by tomr303 on Aug 8, 2018
Latest reply on Aug 9, 2018 by tomr303

Product and version (e.g. FileMaker Pro 14.0.3)

FMP 17 Advanced v 17.0.2.205

OS and version

macOS High Sierra v 10.13.6

Browser and version (for WebDirect only)

n/a

Hardware

MacBook Pro 13-inch, 2017

Description

UniqueValues function omits some unique values

How to replicate

exported all values to a CSV file, imported into a new .fmp12 file, and wrote a test script using UniqueValues and got the same result - certain unique values were not returned by the UniqueValues function. Also, I copied my solution file to a 2013 iMac and received the same result under FMP 16 Advanced.

Workaround (if any)

None found.

 

The values are in a calculation field that uses JSONSetELement to collect the values of other fields, and then substituting the | character for the double quotation mark (to make finds easier, without having to handle " as a special character). The values are collected into a variable ($tranches) using the List function, and then I'm setting a 2nd variable using UniqueValues ( $tranches ; 1 ).

 

I'm attaching text files with all values and those returned by UniqueValues. The values that are omitted (but expected to be returned) include the strings "trk_8461" (line 76) and "trk_8463" (lines 67, 69, and elsewhere). It's possible other unique values are also being omitted, but these are the ones I've found so far.

 

Thanks,

Tom

 

Edit

 

Just realized this may be an operator error - the values include curly braces, which I think may be reserved characters, like quotation marks?

Attachments

Outcomes