justinc

External Data Source reference issue

Discussion created by justinc on Aug 10, 2018

I ran into a problem recently with a client.  They have a server they host locally on their office network - there's a wireless router (Apple Time Capsule) that the server (a mac Mini) is plugged into, and the other computers connect to the Time Capsule, either wirelessly or by network cable.

 

I created launcher files for them that would open a couple of their hosted files, with their own accounts.  When defining the external data sources in these files, I used 192.168.1.10 (the somewhat-fixed IP address of their server).  (I say 'somewhat' because the router is configured to always assign that IP to that machine, based on MAC address.)  The server is named "server1", and it is available as "server1.local".

 

The launcher files for 3 of the users didn't work - it wouldn't open the remote files, giving them an Error 802 ("unable to open file").  1 person in the office, things worked just fine.  When I went back into their office to troubleshoot, everything I did from one of these problem computers indicated that 192.168.1.10 would correctly connect to their server:

• Open Remote, Define new Host, address = 192.168.1.10 => I see a list of files

• Pinged "server1.local" => resolved to 192.168.1.10 (pings came back OK)

• Pinged 192.168.1.10 => pings came back OK

• After connecting to a hosted file, using "get(hostipaddress)" returns 192.168.1.10

 

So what's the deal?  Why couldn't that IP address be used for some reason, from most of the computers?  I was thinking there might be a network configuration difference on these other machines.  Or is it a Bonjour issue?

 

I fixed the immediate problem by changing the external data sources to use "server1.local" as the EDS.

 

Thanks,
Justin

Outcomes