user25648

Cannot delete record, recovery had no errors

Discussion created by user25648 on Aug 12, 2018
Latest reply on Aug 13, 2018 by gdurniak

In trying to delete a batch of found records, Filemaker was getting "hung up" - I had to force quit.  By using a backup copy, I've isolated one record which is causing the problem.  I can delete all the other records except this one.

 

Problem is, I do not get any messages, errors or other feedback from Filemaker.  It just hangs up.

 

I've taken a good backup, compacted, recovered, etc, etc.  But, despite everything I've done, I cannot delete the record.  It doesn't look corrupt - it's a real record.  All the links appear to be setup properly.  In a "testing" backup I went so far as to delete all related records in other tables, leaving only this one to delete.

 

I've also tried a suggestion on another discussion to "Recover the file using advanced recover options: Copy File Blocks as Is, Rebuild indexes now" - this, too, did not work.

 

I'm at a loss as to what to do.  I synchronize this data file with another every night, and this one blasted record causes the whole thing to fail by causing FileMaker to hang up.

 

Any suggestions as to what I can do?  I really don't want to have to re-create the entire datafile ... it is a 10Gb size with text (no images or containers) with >20 tables which would need to be re-created - I'm concerned with unintended consequences resulting from such a task.

 

Thanks for any help!

Outcomes